Problems using SetMainDataDir with Matlab and ActiveX

Hans Schmid

Posted on 04.01.2017 16:45

Hey there,

I have some problems with the automation of DeweSoft 7.1 using Matlab. The command "SetMainDataDir" sometimes doesn't take effect.

In most cases Dewesoft gets the new directory on the first run of my tool, but not on the following. Clearing and new initalizing the ActiveX server doesn't help.

Only a restart can solve the problem for the next run. Also I tried to refresh the screen with UpdateSetupScreen which didn't help, too.

The syntax of my tool should be okay and the debugger has no errors or warning. Some other commands - like LoadSetup - in the same function/script are still working.

May some of you had the same problem and can help me.

Best Regards

Hans Schmid

DEWESoft Support
Technical support
Posted on 06.01.2017 07:24

Hi,

I've attached a video where I'm controlling DEWESoft with Python. It's not MATLAB, but the commands are still the same. I have a notepad with some example paths to the right of the recording screen, which I'm pasting into the IPython console. As you can see, the storing path always gets correctly changed in DEWESoft V7.1.3. Are you maybe using an older version?

Also, are there are any particular paths that don't take effect, or does the command always stop working for you after the first call?


Attached files:
Login to reply to this topic. If you don't have account yet, you can signup for free account .
This website uses cookies to ensure you get the best experience on our website. Learn more