FFT from downsampled signal

Felix Bodenmüller

Posted on 30.03.2017 09:05

Hello,

I'm having recorded data with Dewesoft, where I used a sampling rate of 50 kS/sec. The sampling rate has been chose, because we need to look at harmonic content up to about 15 kHz.

Now I also want to see the frequency spectrum of the signal in the area between 10 Hz and 100 Hz.

Unfortunately the frequency resolution is limited to df = 1,53 Hz (N = 16k). (32k or 64k cannot be selected.)

Is it somehow possible that I downsample my signals to e.g. 5 kS/sec and then make a FFT of it, where with N = 16k it would result in a frequency resolution of 0,153Hz?


Regards.

Primož Gorenšek
Automotive Application Engineer
Posted on 30.03.2017 13:51

It's possible to reduce the data with offline math and then export those channels.

If you have acquired the data with a 200 kHz sampling rate and you would like to export the data with a 20 kHz sampling rate, you need to export only every 10th sample. To do this:
1. go to offline math (setup)
2. Add math
3. Basic statistics
4. Under output channels select only "average" and under calculation type "Block based" and sample based. Block size should be 10 samples if you would like to reduce the data for a factor of 10 (or you can define the block size in terms of time).
5. You can select multiple or all channels in the formula and you will have reduced data for all channels at once. Then you can export the these channels into a new DEWESoft file and therefore reduce the number of samples.
Another option is to use a filter and the sample rate divider option. Please refer to the attached image (filter.png).



Best regards,

Primoz


Attached files:
Primož Gorenšek
Automotive Application Engineer
Posted on 31.03.2017 07:18

Hi Felix,

Instead of reducing the sample rate, it is also possible to use 32K or 64K frequency resolution on the existing file. Please go to settings -> Performance -> Memory -> Sync DC buffer length -> increase to 10seconds.


Best regards,

Primoz

Felix Bodenmüller

Posted on 31.03.2017 15:05

Hello Primoz,

thanks a lot!

Increasing the Sync DC Buffer length helped!

Regards,

Felix

Login to reply to this topic. If you don't have account yet, you can signup for free account .
This website uses cookies to ensure you get the best experience on our website. Learn more